Results 1 to 1 of 1

Thread: Precomp CRC error

  1. #1
    Member
    Join Date
    Dec 2010
    Location
    turkey
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Precomp CRC error

    Hi,

    My problem is precomp when decompressing.

    arc.ini:
    Code:
    [External compressor:precomp]
    header = 0
    packcmd   = precomp -intense -c-  {options} -o$$arcpackedfile$$.tmp  $$arcdatafile$$.tmp
    unpackcmd = precomp -o$$arcdatafile$$.tmp -r $$arcpackedfile$$.tmp

    compress:
    Code:
    arc a -ep1 -r -ed -lc512 -ld512 -mt1 -mprecomp+delta+lzma:a1:mfbt4:d158m:fb273:mc1000:lc8 "C:\pack\test.arc" "C:\pack\test\*"
    
    
    100.00% - New size: 1033857462 instead of 1760634392
    
    
    Done.
    Time: 15 minutes, 45 seconds
    
    
    Recompressed streams: 3894/6964
    GZip streams: 0/6
    PNG streams: 53/227
    PNG streams (multi): 50/63
    zLib streams (intense mode): 3791/6668
    
    
    You can speed up Precomp for THIS FILE with these parameters:
    -zl38,64,68,98 -d0
    
    
    Errorlevel=0
    Compressed 1 file, 1,760,634,392 => 1,044,793,889 bytes. Ratio 59.34%
    Compression time: cpu 400.69 sec/real 1354.96 sec = 30%. Speed 1.30 mB/s
    All OK

    decompress with unarc.exe:
    Code:
    unarc.exe x -dpunpacked\ test.arc
    
    result:
    ERROR: file unpacked\tscex15V1.cpk failed CRC check
    decompress with arc.exe:
    Code:
    arc.exe x -dpunpacked\ test.arc
    
    result:
    arc.exe: wclose: invalid argument (Bad file descriptor)
    ERROR: CRC failed in "unpacked\tscex15V1.cpk". File is broken.


    I use a different version of Precomp (0.38, 0.40, 0.41, 0.42, 0.43), but same problem.

    I changed switch of Precomp:
    precomp -intense -c- -t-j
    precomp -intense -t-j
    precomp -intense
    precomp -intense -mjpeg- -t- -c-

    result: CRC error


    and last switch:
    precomp -c-

    result: no CRC error

    This CRC problem occurs when some files in -intense mode.


    What is the problem?


    Thanks.
    Last edited by tanerjames; 19th April 2015 at 20:12.

Similar Threads

  1. Private Internet Access PIA VPN 403 error
    By cbloom in forum The Off-Topic Lounge
    Replies: 2
    Last Post: 3rd February 2015, 06:46
  2. Freearc error [help]
    By rafikhan in forum Data Compression
    Replies: 0
    Last Post: 1st July 2014, 01:18
  3. Precomp0.4.2 zlib error
    By jason73 in forum Data Compression
    Replies: 3
    Last Post: 19th December 2011, 11:47
  4. precomp error: std::bad_alloc
    By lohem in forum Data Compression
    Replies: 12
    Last Post: 11th November 2011, 20:58
  5. Error recovery from archive?
    By roytam1 in forum The Off-Topic Lounge
    Replies: 15
    Last Post: 9th November 2011, 11:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •